# CVE-2023-30620: Arbitrary File Write when Extracting a Remotely retrieved Tarball in mindsdb/mindsdb

> An attacker can overwrite arbitrary local files by exploiting unsafe tarball extraction in MindsDB, requiring an upgrade to mitigate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2023
- **Updated:** 4 Feb 2025
- **Also known as:** GHSA-2g5w-29q9-w6hx, PYSEC-2023-27

## What is CVE-2023-30620?

CVE-2023-30620 is a high-severity path traversal vulnerability in mindsdb, published on 21 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mindsdb is a Machine Learning platform to help developers build AI solutions. In affected versions an unsafe extraction is being performed using `tarfile.extractall()` from a remotely retrieved tarball. Which may lead to the writing of the extracted files to an unintended location. Sometimes, the vulnerability is called a TarSlip or a ZipSlip variant. An attacker may leverage this vulnerability to overwrite any local file which the server process has access to. There is no risk of file exposure with this vulnerability. This issue has been addressed in release `23.2.1.0 `. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-30620?

3 open source packages ship an affected version, including mindsdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mindsdb` | PyPI | All versions | 23.2.1.0 |
| `mindsdb` | PyPI | All versions | 23.2.1.0 |
| `mindsdb` | PyPI | All versions | 23.2.1.0 |

Products: Mindsdb Mindsdb.

## How do I fix CVE-2023-30620?

Upgrade mindsdb to 23.2.1.0 or later.

## Is CVE-2023-30620 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30620 exists.

## Other vulnerabilities in mindsdb

- [CVE-2024-24759](https://insights.sbomify.com/CVE-2024-24759/): MindsDB Vulnerable to Bypass of SSRF Protection with DNS Rebinding (critical 9.3)
- [CVE-2023-50731](https://insights.sbomify.com/CVE-2023-50731/): MindsDB has arbitrary file write in file.py (critical 9.1)
- [CVE-2023-38699](https://insights.sbomify.com/CVE-2023-38699/): MindsDB 'Call to requests with verify=False disabling SSL certificate checks, security issue.' issue (critical 9.1)
- [CVE-2024-45856](https://insights.sbomify.com/CVE-2024-45856/): MindsDB Cross-site Scripting vulnerability (critical 9.0)
- [CVE-2026-27483](https://insights.sbomify.com/CVE-2026-27483/): MindsDB has Path Traversal in /api/files Leading to Remote Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30620 and fix it if it is affected.

What it is: CVE-2023-30620 is a high-severity path traversal vulnerability in mindsdb, published on 21 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30620 exists.

Affected packages and fixed versions:
- mindsdb (PyPI): affected all versions; fixed in 23.2.1.0
- mindsdb (PyPI): affected all versions; fixed in 23.2.1.0
- mindsdb (PyPI): affected all versions; fixed in 23.2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30620/ (Markdown: https://insights.sbomify.com/CVE-2023-30620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30620
- OSV: https://osv.dev/vulnerability/CVE-2023-30620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30620/
Summaries are generated and may contain mistakes; the official description above is the record.
