# CVE-2023-30624: Wasmtime has Undefined Behavior in Rust runtime functions

> Undefined behavior in Wasmtime's unsafe Rust code can lead to memory corruption and potential code execution when compiled with specific LLVM versions.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2023
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-ch89-5g45-qwc7, RUSTSEC-2023-0092

## What is CVE-2023-30624?

CVE-2023-30624 is a low-severity memory corruption vulnerability in bytecodealliance wasmtime, published on 27 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Wasmtime is a standalone runtime for WebAssembly. Prior to versions 6.0.2, 7.0.1, and 8.0.1, Wasmtime's implementation of managing per-instance state, such as tables and memories, contains LLVM-level undefined behavior. This undefined behavior was found to cause runtime-level issues when compiled with LLVM 16 which causes some writes, which are critical for correctness, to be optimized away. Vulnerable versions of Wasmtime compiled with Rust 1.70, which is currently in beta, or later are known to have incorrectly compiled functions. Versions of Wasmtime compiled with the current Rust stable release, 1.69, and prior are not known at this time to have any issues, but can theoretically exhibit potential issues.

The underlying problem is that Wasmtime's runtime state for an instance involves a Rust-defined structure called `Instance` which has a trailing `VMContext` structure after it. This `VMContext` structure has a runtime-defined layout that is unique per-module. This representation cannot be expressed with safe code in Rust so `unsafe` code is required to maintain this state. The code doing this, however, has methods which take `&self` as an argument but modify data in the `VMContext` part of the allocation. This means that pointers derived from `&self` are mutated. This is typically not allowed, except in the presence of `UnsafeCell`, in Rust. When compiled to LLVM these functions have `noalias readonly` parameters which means it's UB to write through the pointers.

Wasmtime's internal representation and management of `VMContext` has been updated to use `&mut self` methods where appropriate. Additionally verification tools for `unsafe` code in Rust, such as `cargo miri`, are planned to be executed on the `main` branch soon to fix any Rust-level issues that may be exploited in future compiler versions.

Precomplied binaries available for Wasmtime from GitHub releases have been compiled with at most LLVM 15 so are not known to be vulnerable. As mentioned above, however, it's still recommended to update.

Wasmtime version 6.0.2, 7.0.1, and 8.0.1 have been issued which contain the patch necessary to work correctly on LLVM 16 and have no known UB on LLVM 15 and earlier. If Wasmtime is compiled with Rust 1.69 and prior, which use LLVM 15, then there are no known issues. There is a theoretical possibility for undefined behavior to exploited, however, so it's recommended that users upgrade to a patched version of Wasmtime. Users using beta Rust (1.70 at this time) or nightly Rust (1.71 at this time) must update to a patched version to work correctly.

Weakness: CWE-758 (Reliance on Undefined, Unspecified, or Implementation-Defined Behavior)

## Which versions are affected by CVE-2023-30624?

7 open source packages ship an affected version, including wasmtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | All versions | 6.0.2 |
| `wasmtime` | crates.io | All versions | 6.0.2 |
| `wasmtime` | crates.io | From 0.0.0-0 | 6.0.2, 7.0.1, 8.0.1 |
| `wasmtime` | crates.io | From 7.0.0 | 7.0.1 |
| `wasmtime` | crates.io | From 7.0.0 | 7.0.1 |
| `wasmtime` | crates.io | From 8.0.0 | 8.0.1 |
| `wasmtime` | crates.io | From 8.0.0 | 8.0.1 |

Products: Bytecodealliance Wasmtime.

## How do I fix CVE-2023-30624?

Upgrade wasmtime to a fixed version for your release line: 6.0.2, 7.0.1 or 8.0.1.

## Is CVE-2023-30624 being exploited?

There is no known exploitation of CVE-2023-30624 in the wild and no public exploit code.

## Other vulnerabilities in bytecodealliance wasmtime

- [CVE-2026-34971](https://insights.sbomify.com/CVE-2026-34971/): Wasmtime miscompiled guest heap access enables sandbox escape on aarch64 Cranelift (critical 9.0)
- [CVE-2026-34987](https://insights.sbomify.com/CVE-2026-34987/): Wasmtime with Winch compiler backend on aarch64 may allow a sandbox-escaping memory access (critical 9.0)
- [CVE-2022-39393](https://insights.sbomify.com/CVE-2022-39393/): Wasmtime vulnerable to data leakage between instances in the pooling allocator (high 8.6)
- [CVE-2022-24791](https://insights.sbomify.com/CVE-2022-24791/): Use after free in Wasmtime (high 8.1)
- [CVE-2026-47261](https://insights.sbomify.com/CVE-2026-47261/): Wasmtime: WASI path_open(TRUNCATE) bypasses `FilePerms::WRITE` host restriction (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30624 and fix it if it is affected.

What it is: CVE-2023-30624 is a low-severity memory corruption vulnerability in bytecodealliance wasmtime, published on 27 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30624 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected all versions; fixed in 6.0.2
- wasmtime (crates.io): affected all versions; fixed in 6.0.2
- wasmtime (crates.io): affected from 0.0.0-0; fixed in 6.0.2, 7.0.1, 8.0.1
- wasmtime (crates.io): affected from 7.0.0; fixed in 7.0.1
- wasmtime (crates.io): affected from 7.0.0; fixed in 7.0.1
- wasmtime (crates.io): affected from 8.0.0; fixed in 8.0.1
- wasmtime (crates.io): affected from 8.0.0; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30624/ (Markdown: https://insights.sbomify.com/CVE-2023-30624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30624
- OSV: https://osv.dev/vulnerability/CVE-2023-30624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30624/
Summaries are generated and may contain mistakes; the official description above is the record.
