CVE-2023-30627 jellyfin-web has a stored cross-site scripting vulnerability in devices.js

Critical 9.1 Published Updated

Stored XSS in Jellyfin web client allows admin-privileged API calls, potentially leading to remote code execution when chained with other vulnerabilities.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2023-30627?

CVE-2023-30627 is a critical cross-site scripting vulnerability in jellyfin-web, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

jellyfin-web is the web client for Jellyfin, a free-software media system. Starting in version 10.1.0 and prior to version 10.8.10, a stored cross-site scripting vulnerability in device.js can be used to make arbitrary calls to the `REST` endpoints with admin privileges. When combined with CVE-2023-30626, this results in remote code execution on the Jellyfin instance in the context of the user who's running it. This issue is patched in version 10.8.10. There are no known workarounds.

Weakness: CWE-79

Which versions are affected by CVE-2023-30627?

It affects 1 product.

Products include Jellyfin Jellyfin.

How do I fix CVE-2023-30627?

No fix has been published for CVE-2023-30627 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-30627 being exploited?

There is no known exploitation of CVE-2023-30627 in the wild and no public exploit code.

Sources

Is CVE-2023-30627 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free