# CVE-2023-30627: jellyfin-web has a stored cross-site scripting vulnerability in devices.js

> Stored XSS in Jellyfin web client allows admin-privileged API calls, potentially leading to remote code execution when chained with other vulnerabilities.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Apr 2023
- **Updated:** 12 Feb 2025

## What is CVE-2023-30627?

CVE-2023-30627 is a critical cross-site scripting vulnerability in jellyfin-web, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

jellyfin-web is the web client for Jellyfin, a free-software media system. Starting in version 10.1.0 and prior to version 10.8.10, a stored cross-site scripting vulnerability in device.js can be used to make arbitrary calls to the `REST` endpoints with admin privileges. When combined with CVE-2023-30626, this results in remote code execution on the Jellyfin instance in the context of the user who's running it. This issue is patched in version 10.8.10. There are no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-30627?

It affects 1 product.


Products: Jellyfin Jellyfin.

## How do I fix CVE-2023-30627?

No fix has been published for CVE-2023-30627 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-30627 being exploited?

There is no known exploitation of CVE-2023-30627 in the wild and no public exploit code.

## Other vulnerabilities in jellyfin-web

- [CVE-2026-35031](https://insights.sbomify.com/CVE-2026-35031/): Jellyfin: Potential RCE via subtitle upload path traversal + .strm chain (critical 10.0)
- [CVE-2026-31852](https://insights.sbomify.com/CVE-2026-31852/): Jellyfin Possible Organization/Secret Compromise from dangerous CI implementation (critical 10.0)
- [CVE-2026-35033](https://insights.sbomify.com/CVE-2026-35033/): Jellyfin: Potential SSRF + Arbitrary file read via stream argument injection (critical 9.3)
- [CVE-2023-30626](https://insights.sbomify.com/CVE-2023-30626/): Jellyfin vulnerable to directory traversal and file write causing arbitrary code execution (high 8.8)
- [CVE-2022-35909](https://insights.sbomify.com/CVE-2022-35909/): Incorrect Access Control and Cross Site Scripting in Jellyfin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30627 and fix it if it is affected.

What it is: CVE-2023-30627 is a critical cross-site scripting vulnerability in jellyfin-web, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-30627 in the wild and no public exploit code.

Affected product: jellyfin-web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30627/ (Markdown: https://insights.sbomify.com/CVE-2023-30627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30627
- OSV: https://osv.dev/vulnerability/CVE-2023-30627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30627/
Summaries are generated and may contain mistakes; the official description above is the record.
