CVE-2023-30631 Apache Traffic Server: Configuration option to block the PUSH method in ATS didn't work

High 7.5 Published Updated

A configuration option to block the HTTP PUSH method failed, potentially allowing unauthorized method usage if default ip_allow rules are altered.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-30631?

CVE-2023-30631 is a high-severity vulnerability in Apache Traffic Server, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.  The configuration option proxy.config.http.push_method_enabled didn't function.  However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0.

8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

Weakness: CWE-20

Which versions are affected by CVE-2023-30631?

It affects 3 products.

Products include Apache Traffic Server, Debian Debian Linux, Fedoraproject Fedora.

How do I fix CVE-2023-30631?

Upgrade to a fixed version.

Is CVE-2023-30631 being exploited?

There is no known exploitation of CVE-2023-30631 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-30631, GHSA-5rc2-qffv-3c8p, UBUNTU-CVE-2023-30631.

Is CVE-2023-30631 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free