CVE-2023-3072 Nomad ACL Policies without Label are Applied to Unexpected Resources
Attackers can bypass ACL restrictions and access unexpected resources due to improper handling of unlabeled policy blocks in HashiCorp Nomad.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3072?
CVE-2023-3072 is a medium-severity missing authorization vulnerability in HashiCorp Nomad, published on 19 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
HashiCorp Nomad and Nomad Enterprise 0.7.0 up to 1.5.6 and 1.4.10 ACL policies using a block without a label generates unexpected results. Fixed in 1.6.0, 1.5.7, and 1.4.11.
Which versions are affected by CVE-2023-3072?
5 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/nomad Go | From 0.7.0 | 1.4.11, 1.5.6 |
github.com/hashicorp/nomad Go | From 0.7.0 | 1.4.11 |
github.com/hashicorp/nomad Go | From 0.7.0 | 1.4.11 |
github.com/hashicorp/nomad Go | From 1.5.0 | 1.5.6 |
github.com/hashicorp/nomad Go | From 1.5.0 | 1.5.6 |
Products include Hashicorp Nomad.
How do I fix CVE-2023-3072?
Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.4.11 or 1.5.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-3072 being exploited?
There is no known exploitation of CVE-2023-3072 in the wild and no public exploit code.
Other vulnerabilities in HashiCorp Nomad
- CVE-2023-1782 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation
- CVE-2022-30324 Privilege escalation in Hashicorp Nomad
- CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad
- CVE-2019-12618 Hashicorp Nomad Access Control Issues
- CVE-2020-27195 Use After Free in HashiCorp Nomad
Sources
Also known as GHSA-rpvr-38xv-xvxq, GO-2024-2670, UBUNTU-CVE-2023-3072.