{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30776 in the wild and no public exploit code.","fix":"Upgrade apache-superset to 2.1.0 or later.","what":"CVE-2023-30776 is a medium-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30776 and fix it if it is affected.\n\nWhat it is: CVE-2023-30776 is a medium-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30776 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0\n- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0\n- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0\n- superset (Bitnami): affected from 1.3.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30776/ (Markdown: https://insights.sbomify.com/CVE-2023-30776/index.md)","id":"CVE-2023-30776","markdown":"https://insights.sbomify.com/CVE-2023-30776/index.md","name":"CVE-2023-30776","record":{"aliases":["BIT-superset-2023-30776","GHSA-cmjc-52fg-9f7j","PYSEC-2026-1171"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"high_privilege","summary":"Authenticated users with specific permissions can leak database connection passwords via a REST API endpoint in Apache Superset.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. This issue affects Apache Superset version 1.3.0 up to 2.0.1.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Database connection password leak","id":"CVE-2023-30776","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"information_disclosure","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"WordPress Advanced Custom Fields / Advanced Custom Fields PRO plugins \u003c= 6.1.5 vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-30777"},"packages":[{"ecosystem":"Bitnami","fixed":["2.0.2"],"introduced":["1.3.0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2023-30776"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["1.3.0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-cmjc-52fg-9f7j"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["1.3.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-cmjc-52fg-9f7j"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["1.3.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1171"}],"prev":{"headline":"Memory corruption in libtiff","id":"CVE-2023-30775"},"products":["Apache Superset"],"published":"2023-04-24","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-21","vendors":["Apache Software Foundation"]},"summary":"Authenticated users with specific permissions can leak database connection passwords via a REST API endpoint in Apache Superset.","url":"https://insights.sbomify.com/CVE-2023-30776/"}