# CVE-2023-30776: Apache Superset: Database connection password leak

> Authenticated users with specific permissions can leak database connection passwords via a REST API endpoint in Apache Superset.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2023
- **Updated:** 21 Oct 2024
- **Also known as:** BIT-superset-2023-30776, GHSA-cmjc-52fg-9f7j, PYSEC-2026-1171

## What is CVE-2023-30776?

CVE-2023-30776 is a medium-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. This issue affects Apache Superset version 1.3.0 up to 2.0.1.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-30776?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | From 1.3.0 | 2.1.0 |
| `apache-superset` | PyPI | From 1.3.0 | 2.1.0 |
| `apache-superset` | PyPI | From 1.3.0 | 2.1.0 |
| `superset` | Bitnami | From 1.3.0 | 2.0.2 |

Products: Apache Superset.

## How do I fix CVE-2023-30776?

Upgrade apache-superset to 2.1.0 or later.

## Is CVE-2023-30776 being exploited?

There is no known exploitation of CVE-2023-30776 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30776 and fix it if it is affected.

What it is: CVE-2023-30776 is a medium-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30776 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0
- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0
- apache-superset (PyPI): affected from 1.3.0; fixed in 2.1.0
- superset (Bitnami): affected from 1.3.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30776/ (Markdown: https://insights.sbomify.com/CVE-2023-30776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30776
- OSV: https://osv.dev/vulnerability/CVE-2023-30776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30776/
Summaries are generated and may contain mistakes; the official description above is the record.
