{"answers":{"affected":"It affects 4 products.","exploited":"Yes. Attackers have exploited CVE-2023-3079 in the wild since at least 7 Jun 2023.","fix":"Upgrade to a fixed version. US federal agencies must fix it by 28 Jun 2023.","what":"CVE-2023-3079 is a high-severity memory corruption vulnerability in Couchbase Couchbase Server, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-3079 and fix it if it is affected.\n\nWhat it is: CVE-2023-3079 is a high-severity memory corruption vulnerability in Couchbase Couchbase Server, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2023-3079 in the wild since at least 7 Jun 2023.\n\nAffected product: Couchbase Couchbase Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3079/ (Markdown: https://insights.sbomify.com/CVE-2023-3079/index.md)","id":"CVE-2023-3079","markdown":"https://insights.sbomify.com/CVE-2023-3079/index.md","name":"CVE-2023-3079","record":{"aliases":["DEBIAN-CVE-2023-3079","DSA-5420-1","GHSA-8mwf-hvfp-6xfg","openSUSE-SU-2023:0123-1","openSUSE-SU-2024:12985-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Chrome","requires_auth":"none","summary":"A type confusion flaw in Chrome's V8 engine allows remote attackers to execute arbitrary code via a crafted HTML page.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"couchbase_server","vendor":"couchbase"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"chrome","vendor":"google"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Type confusion in V8 in Google Chrome prior to 114.0.5735.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2023-08-15","github_poc":1,"max_poc_stars":131,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-08-15T04:16:46Z","kind":"github_poc","ref":"https://github.com/mistymntncop/CVE-2023-3079","stars":131,"title":null}],"tier":"exploited"},"has_fix":true,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2023-3079","indexable":true,"kev":{"dateAdded":"2023-06-07","dueDate":"2023-06-28","knownRansomwareCampaignUse":"Unknown","product":"Chromium V8","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Google","vulnerabilityName":"Google Chromium V8 Type Confusion Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":"couchbase:couchbase_server","products":["couchbase:couchbase_server","debian:debian_linux","fedoraproject:fedora","google:chrome"],"type":"memory_corruption","year":"2023"},"n_packages":3,"n_references":10,"next":{"headline":"WP Mail Catcher \u003c= 2.1.2 - Unauthenticated Stored Cross-Site Scripting via Email Subject","id":"CVE-2023-3080"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["114.0.5735.106-bp155.2.4.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/suse/chromium\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2023:0123-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["114.0.5735.106-bp155.2.4.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2023:0123-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["114.0.5735.106-1.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12985-1"}],"prev":{"headline":"Path traversal in Universal Device Client (UDC)","id":"CVE-2023-3078"},"products":["Chrome"],"published":"2023-06-05","related":[{"cvss_score":8.8,"headline":"Google Chromium V8 Out-of-Bounds Memory Access","id":"CVE-2024-0519","kev_date_added":"2024-01-17","published":"2024-01-16"},{"cvss_score":8.8,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2023-2033","kev_date_added":"2023-04-17","published":"2023-04-14"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2023-49930","kev_date_added":null,"published":"2024-02-28"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2023-49931","kev_date_added":null,"published":"2024-02-28"},{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2021-35943","kev_date_added":null,"published":"2021-09-29"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2020-24719","kev_date_added":null,"published":"2020-11-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["Google"]},"summary":"A type confusion flaw in Chrome's V8 engine allows remote attackers to execute arbitrary code via a crafted HTML page.","url":"https://insights.sbomify.com/CVE-2023-3079/"}