# CVE-2023-30797: Insecure Random Generation in Netflix Lemur

> Attackers can guess default credentials due to insecure random generation, gaining unauthorized access to resources managed by Netflix Lemur.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-5fqv-mpj8-h7gm, PYSEC-2023-20

## What is CVE-2023-30797?

CVE-2023-30797 is a high-severity vulnerability in Netflix Lemur, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netflix Lemur before version 1.3.2 used insufficiently random values when generating default credentials. The insufficiently random values may allow an attacker to guess the credentials and gain access to resources managed by Lemur.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2023-30797?

3 open source packages ship an affected version, including lemur. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.3.2 |
| `lemur` | PyPI | All versions | 1.3.2 |
| `lemur` | PyPI | All versions | 1.3.2 |

Products: Netflix Lemur.

## How do I fix CVE-2023-30797?

Upgrade lemur to 1.3.2 or later.

## Is CVE-2023-30797 being exploited?

There is no known exploitation of CVE-2023-30797 in the wild and no public exploit code.

## Other vulnerabilities in Netflix Lemur

- [CVE-2015-7764](https://insights.sbomify.com/CVE-2015-7764/): Lemur uses static IV per key (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30797 and fix it if it is affected.

What it is: CVE-2023-30797 is a high-severity vulnerability in Netflix Lemur, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30797 in the wild and no public exploit code.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.3.2
- lemur (PyPI): affected all versions; fixed in 1.3.2
- lemur (PyPI): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30797/ (Markdown: https://insights.sbomify.com/CVE-2023-30797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30797
- OSV: https://osv.dev/vulnerability/CVE-2023-30797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30797/
Summaries are generated and may contain mistakes; the official description above is the record.
