CVE-2023-30838 PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method
Attackers can execute arbitrary scripts via XSS in PrestaShop, potentially leading to account takeover or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-30838?
CVE-2023-30838 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.
Weakness: CWE-79
Which versions are affected by CVE-2023-30838?
4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
Products include Prestashop Prestashop.
How do I fix CVE-2023-30838?
Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.9 or 8.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-30838 being exploited?
There is no known exploitation of CVE-2023-30838 in the wild and no public exploit code.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-fh7r-996q-gvcp.