{"answers":{"affected":"4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30838 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.9 or 8.0.4.","what":"CVE-2023-30838 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30838 and fix it if it is affected.\n\nWhat it is: CVE-2023-30838 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30838 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.9\n- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.9\n- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.4\n- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30838/ (Markdown: https://insights.sbomify.com/CVE-2023-30838/index.md)","id":"CVE-2023-30838","markdown":"https://insights.sbomify.com/CVE-2023-30838/index.md","name":"CVE-2023-30838","record":{"aliases":["GHSA-fh7r-996q-gvcp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop e-commerce","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts via XSS in PrestaShop, potentially leading to account takeover or code execution.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method","id":"CVE-2023-30838","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"xss","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.8.9"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-fh7r-996q-gvcp"},{"ecosystem":"Packagist","fixed":["1.7.8.9"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-fh7r-996q-gvcp"},{"ecosystem":"Packagist","fixed":["8.0.4"],"introduced":["8.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-fh7r-996q-gvcp"},{"ecosystem":"Packagist","fixed":["8.0.4"],"introduced":["8.0.0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-fh7r-996q-gvcp"}],"prev":{"headline":"Vyper storage allocator overflow","id":"CVE-2023-30837"},"products":["PrestaShop"],"published":"2023-04-25","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-03","vendors":["PrestaShop"]},"summary":"Attackers can execute arbitrary scripts via XSS in PrestaShop, potentially leading to account takeover or code execution.","url":"https://insights.sbomify.com/CVE-2023-30838/"}