# CVE-2023-30838: PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method

> Attackers can execute arbitrary scripts via XSS in PrestaShop, potentially leading to account takeover or code execution.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 3 Feb 2025
- **Also known as:** GHSA-fh7r-996q-gvcp

## What is CVE-2023-30838?

CVE-2023-30838 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-30838?

4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.9 |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.9 |
| `prestashop/prestashop` | Packagist | From 8.0.0 | 8.0.4 |
| `prestashop/prestashop` | Packagist | From 8.0.0 | 8.0.4 |

Products: Prestashop Prestashop.

## How do I fix CVE-2023-30838?

Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.9 or 8.0.4.

## Is CVE-2023-30838 being exploited?

There is no known exploitation of CVE-2023-30838 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30838 and fix it if it is affected.

What it is: CVE-2023-30838 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30838 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.9
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.9
- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.4
- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30838/ (Markdown: https://insights.sbomify.com/CVE-2023-30838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30838
- OSV: https://osv.dev/vulnerability/CVE-2023-30838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30838/
Summaries are generated and may contain mistakes; the official description above is the record.
