CVE-2023-30839 PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager"
A SQL filter bypass in PrestaShop allows back-office users to perform unauthorized database write, update, and delete operations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-30839?
CVE-2023-30839 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PrestaShop is an Open Source e-commerce web application. Versions prior to 8.0.4 and 1.7.8.9 contain a SQL filtering vulnerability. A BO user can write, update, and delete in the database, even without having specific rights. PrestaShop 8.0.4 and 1.7.8.9 contain a patch for this issue. There are no known workarounds.
Weakness: CWE-89
Which versions are affected by CVE-2023-30839?
4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | All versions | 1.7.8.9 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.4 |
Products include Prestashop Prestashop.
How do I fix CVE-2023-30839?
Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.9 or 8.0.4.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2023-30839 being exploited?
There is no known exploitation of CVE-2023-30839 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-p379-cxqh-q822.