CVE-2023-30845 ESPv2 vulnerable to JWT authentication bypass via `X-HTTP-Method-Override` header
Attackers can bypass JWT authentication in ESPv2 by crafting a malicious X-HTTP-Method-Override header, allowing unauthorized access to backend services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-30845?
CVE-2023-30845 is a high-severity authentication bypass vulnerability in GoogleCloudPlatform esp-v2, published on 26 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ESPv2 is a service proxy that provides API management capabilities using Google Service Infrastructure. ESPv2 2.20.0 through 2.42.0 contains an authentication bypass vulnerability. API clients can craft a malicious `X-HTTP-Method-Override` header value to bypass JWT authentication in specific cases.
ESPv2 allows malicious requests to bypass authentication if both the conditions are true: The requested HTTP method is **not** in the API service definition (OpenAPI spec or gRPC `google.api.http` proto annotations, and the specified `X-HTTP-Method-Override` is a valid HTTP method in the API service definition. ESPv2 will forward the request to your backend without checking the JWT. Attackers can craft requests with a malicious `X-HTTP-Method-Override` value that allows them to bypass specifying JWTs. Restricting API access with API keys works as intended and is not affected by this vulnerability.
Upgrade deployments to release v2.43.0 or higher to receive a patch. This release ensures that JWT authentication occurs, even when the caller specifies `x-http-method-override`. `x-http-method-override` is still supported by v2.43.0+. API clients can continue sending this header to ESPv2.
Weakness: CWE-287
Which versions are affected by CVE-2023-30845?
It affects 1 product.
Products include Google Espv2.
How do I fix CVE-2023-30845?
No fix has been published for CVE-2023-30845 yet. Limit exposure of the affected software until one is available.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-30845 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30845 exists.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-6qmp-9p95-fc5f.