{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30845 exists.","fix":"No fix has been published for CVE-2023-30845 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-30845 is a high-severity authentication bypass vulnerability in GoogleCloudPlatform esp-v2, published on 26 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30845 and fix it if it is affected.\n\nWhat it is: CVE-2023-30845 is a high-severity authentication bypass vulnerability in GoogleCloudPlatform esp-v2, published on 26 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30845 exists.\n\nAffected product: GoogleCloudPlatform esp-v2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30845/ (Markdown: https://insights.sbomify.com/CVE-2023-30845/index.md)","id":"CVE-2023-30845","markdown":"https://insights.sbomify.com/CVE-2023-30845/index.md","name":"CVE-2023-30845","record":{"aliases":["GHSA-6qmp-9p95-fc5f"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Service proxy","requires_auth":"none","summary":"Attackers can bypass JWT authentication in ESPv2 by crafting a malicious X-HTTP-Method-Override header, allowing unauthorized access to backend services.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"espv2","vendor":"google"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"ESPv2 is a service proxy that provides API management capabilities using Google Service Infrastructure. ESPv2 2.20.0 through 2.42.0 contains an authentication bypass vulnerability. API clients can craft a malicious `X-HTTP-Method-Override` header value to bypass JWT authentication in specific cases.\n\nESPv2 allows malicious requests to bypass authentication if both the conditions are true: The requested HTTP method is **not** in the API service definition (OpenAPI spec or gRPC `google.api.http` proto annotations, and the specified `X-HTTP-Method-Override` is a valid HTTP method in the API service definition. ESPv2 will forward the request to your backend without checking the JWT. Attackers can craft requests with a malicious `X-HTTP-Method-Override` value that allows them to bypass specifying JWTs. Restricting API access with API keys works as intended and is not affected by this vulnerability.\n\nUpgrade deployments to release v2.43.0 or higher to receive a patch. This release ensures that JWT authentication occurs, even when the caller specifies `x-http-method-override`. `x-http-method-override` is still supported by v2.43.0+. API clients can continue sending this header to ESPv2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2023-09-22","github_poc":1,"max_poc_stars":16,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-09-22T01:14:20Z","kind":"github_poc","ref":"https://github.com/himori123/-CVE-2023-30845","stars":16,"title":"Explore CVE 2023-30845 automatically across multiple subdomains"}],"tier":"weaponised"},"has_fix":false,"headline":"ESPv2 vulnerable to JWT authentication bypass via `X-HTTP-Method-Override` header","id":"CVE-2023-30845","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"typed-rest-client vulnerable to potential leak of authentication data to 3rd parties","id":"CVE-2023-30846"},"packages":[],"prev":{"headline":"Mutagen list and monitor operations do not neutralize control characters in text controlled by remote endpoints","id":"CVE-2023-30844"},"products":["esp-v2"],"published":"2023-04-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-03","vendors":["GoogleCloudPlatform"]},"summary":"Attackers can bypass JWT authentication in ESPv2 by crafting a malicious X-HTTP-Method-Override header, allowing unauthorized access to backend services.","url":"https://insights.sbomify.com/CVE-2023-30845/"}