# CVE-2023-30845: ESPv2 vulnerable to JWT authentication bypass via `X-HTTP-Method-Override` header

> Attackers can bypass JWT authentication in ESPv2 by crafting a malicious X-HTTP-Method-Override header, allowing unauthorized access to backend services.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Apr 2023
- **Updated:** 3 Feb 2025
- **Also known as:** GHSA-6qmp-9p95-fc5f

## What is CVE-2023-30845?

CVE-2023-30845 is a high-severity authentication bypass vulnerability in GoogleCloudPlatform esp-v2, published on 26 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ESPv2 is a service proxy that provides API management capabilities using Google Service Infrastructure. ESPv2 2.20.0 through 2.42.0 contains an authentication bypass vulnerability. API clients can craft a malicious `X-HTTP-Method-Override` header value to bypass JWT authentication in specific cases.

ESPv2 allows malicious requests to bypass authentication if both the conditions are true: The requested HTTP method is **not** in the API service definition (OpenAPI spec or gRPC `google.api.http` proto annotations, and the specified `X-HTTP-Method-Override` is a valid HTTP method in the API service definition. ESPv2 will forward the request to your backend without checking the JWT. Attackers can craft requests with a malicious `X-HTTP-Method-Override` value that allows them to bypass specifying JWTs. Restricting API access with API keys works as intended and is not affected by this vulnerability.

Upgrade deployments to release v2.43.0 or higher to receive a patch. This release ensures that JWT authentication occurs, even when the caller specifies `x-http-method-override`. `x-http-method-override` is still supported by v2.43.0+. API clients can continue sending this header to ESPv2.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-30845?

It affects 1 product.


Products: Google Espv2.

## How do I fix CVE-2023-30845?

No fix has been published for CVE-2023-30845 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-30845 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30845 exists.

Public exploit code:

- Explore CVE 2023-30845 automatically across multiple subdomains (github_poc): https://github.com/himori123/-CVE-2023-30845

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30845 and fix it if it is affected.

What it is: CVE-2023-30845 is a high-severity authentication bypass vulnerability in GoogleCloudPlatform esp-v2, published on 26 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30845 exists.

Affected product: GoogleCloudPlatform esp-v2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30845/ (Markdown: https://insights.sbomify.com/CVE-2023-30845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30845
- OSV: https://osv.dev/vulnerability/CVE-2023-30845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30845/
Summaries are generated and may contain mistakes; the official description above is the record.
