{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-3085 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-3085 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-3085 is a low-severity cross-site scripting vulnerability in X-WRT luci, published on 3 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-3085 and fix it if it is affected.\n\nWhat it is: CVE-2023-3085 is a low-severity cross-site scripting vulnerability in X-WRT luci, published on 3 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-3085 in the wild and no public exploit code.\n\nAffected product: X-WRT luci. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3085/ (Markdown: https://insights.sbomify.com/CVE-2023-3085/index.md)","id":"CVE-2023-3085","markdown":"https://insights.sbomify.com/CVE-2023-3085/index.md","name":"CVE-2023-3085","record":{"aliases":["GHSA-444f-v7px-88pm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"X-WRT luci","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the 404 error template handler in X-WRT luci, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"luci","vendor":"x-wrt"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in X-WRT luci up to 22.10_b202303061504. This issue affects the function run_action of the file modules/luci-base/ucode/dispatcher.uc of the component 404 Error Template Handler. The manipulation of the argument request_path leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 22.10_b202303121313 is able to address this issue. The patch is named 24d7da2416b9ab246825c33c213fe939a89b369c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230663.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"X-WRT luci 404 Error Template dispatcher.uc run_action cross site scripting","id":"CVE-2023-3085","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Cross-site Scripting (XSS) - Stored in nilsteampassnet/teampass","id":"CVE-2023-3086"},"packages":[],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in nilsteampassnet/teampass","id":"CVE-2023-3084"},"products":["luci"],"published":"2023-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["X-WRT"]},"summary":"Remote attackers can execute arbitrary scripts via the 404 error template handler in X-WRT luci, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2023-3085/"}