{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-30850 in the wild and no public exploit code.","fix":"Upgrade pimcore/pimcore to 10.5.21 or later.","what":"CVE-2023-30850 is a high-severity SQL injection vulnerability in Pimcore Pimcore, published on 27 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-30850 and fix it if it is affected.\n\nWhat it is: CVE-2023-30850 is a high-severity SQL injection vulnerability in Pimcore Pimcore, published on 27 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-30850 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-30850/ (Markdown: https://insights.sbomify.com/CVE-2023-30850/index.md)","id":"CVE-2023-30850","markdown":"https://insights.sbomify.com/CVE-2023-30850/index.md","name":"CVE-2023-30850","record":{"aliases":["GHSA-jwg4-qcgv-5wg6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary SQL commands via the admin translations API, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pimcore","vendor":"pimcore"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Pimcore is an open source data and experience management platform. Prior to version 10.5.21, a SQL Injection vulnerability exists in the admin translations API. Users should update to version 10.5.21 to receive a patch or, as a workaround, or apply the patch manually.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pimcore SQL Injection Vulnerability in Admin Translations API","id":"CVE-2023-30850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"pimcore:pimcore","products":["pimcore:pimcore"],"type":"sql_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Potential HTTP policy bypass when using header rules in Cilium","id":"CVE-2023-30851"},"packages":[{"ecosystem":"Packagist","fixed":["10.5.21"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-jwg4-qcgv-5wg6"},{"ecosystem":"Packagist","fixed":["10.5.21"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-jwg4-qcgv-5wg6"}],"prev":{"headline":"Pimcore vulnerable to SQL Injection in Translation Export API","id":"CVE-2023-30849"},"products":["pimcore"],"published":"2023-04-27","related":[{"cvss_score":9.8,"headline":"RCE vulnerability in Pimcore/Mail \u0026 Dynamic Text Layout","id":"CVE-2022-39365","kev_date_added":null,"published":"2022-10-27"},{"cvss_score":9.8,"headline":"Pimcore Access Control Issues","id":"CVE-2019-18981","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":9.8,"headline":"Pimcore 2FA Vulnerable to Brute Forcing","id":"CVE-2019-18985","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":8.8,"headline":"Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848","id":"CVE-2026-23492","kev_date_added":null,"published":"2026-01-14"},{"cvss_score":8.8,"headline":"SQL Injection in Admin Grid Filter API in Pimcore","id":"CVE-2023-47637","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"Pimcore SQL Injection Vulnerability in Admin Search Find API","id":"CVE-2023-30848","kev_date_added":null,"published":"2023-04-27"},{"cvss_score":8.8,"headline":"Pimcore vulnerable to SQL Injection in Translation Export API","id":"CVE-2023-30849","kev_date_added":null,"published":"2023-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-30","vendors":["pimcore"]},"summary":"Attackers can execute arbitrary SQL commands via the admin translations API, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2023-30850/"}