# CVE-2023-30852: Pimcore Arbitrary File Read in Admin JS CSS files

> An authenticated administrator can read arbitrary JavaScript and CSS files from the server via path traversal in the script-proxy endpoint.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2023
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-j5c3-r84f-9596

## What is CVE-2023-30852?

CVE-2023-30852 is a medium-severity path traversal vulnerability in Pimcore Pimcore, published on 27 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Pimcore is an open source data and experience management platform. Prior to version 10.5.21, the `/admin/misc/script-proxy` API endpoint that is accessible by an authenticated administrator user is vulnerable to arbitrary JavaScript and CSS file read via the `scriptPath` and `scripts` parameters. The `scriptPath` parameter is not sanitized properly and is vulnerable to path traversal attack. Any JavaScript/CSS file from the application server can be read by specifying sufficient number of `../` patterns to go out from the application webroot followed by path of the folder where the file is located in the "scriptPath" parameter and the file name in the "scripts" parameter. The JavaScript file is successfully read only if the web application has read access to it. Users should update to version 10.5.21 to receive a patch or, as a workaround, apply the patch manual.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-30852?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.21 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.21 |

Products: Pimcore Pimcore.

## How do I fix CVE-2023-30852?

Upgrade pimcore/pimcore to 10.5.21 or later.

## Is CVE-2023-30852 being exploited?

There is no known exploitation of CVE-2023-30852 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30852 and fix it if it is affected.

What it is: CVE-2023-30852 is a medium-severity path traversal vulnerability in Pimcore Pimcore, published on 27 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-30852 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30852/ (Markdown: https://insights.sbomify.com/CVE-2023-30852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30852
- OSV: https://osv.dev/vulnerability/CVE-2023-30852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30852/
Summaries are generated and may contain mistakes; the official description above is the record.
