CVE-2023-30858 Denosaurs emoji has ReDoS vulnerability in `replace` function

Medium 5.3 Published Updated

Attackers can cause denial of service via ReDoS in the replace function of the Denosaurs emoji library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-30858?

CVE-2023-30858 is a medium-severity denial of service vulnerability in denosaurs emoji, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Denosaurs emoji package provides emojis for dinosaurs. Starting in version 0.1.0 and prior to version 0.3.0, the reTrimSpace regex has 2nd degree polynomial inefficiency, leading to a delayed response given a big payload. The issue has been patched in 0.3.0. As a workaround, avoid using the `replace`, `unemojify`, or `strip` functions.

Weakness: CWE-1333

Which versions are affected by CVE-2023-30858?

It affects 1 product.

Products include Denosaurs Emoji.

How do I fix CVE-2023-30858?

No fix has been published for CVE-2023-30858 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-30858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30858 exists.

Sources

Also known as GHSA-w2xx-hjhp-gx5v.

Is CVE-2023-30858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free