# CVE-2023-30858: Denosaurs emoji has ReDoS vulnerability in `replace` function

> Attackers can cause denial of service via ReDoS in the replace function of the Denosaurs emoji library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Apr 2023
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-w2xx-hjhp-gx5v

## What is CVE-2023-30858?

CVE-2023-30858 is a medium-severity denial of service vulnerability in denosaurs emoji, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Denosaurs emoji package provides emojis for dinosaurs. Starting in version 0.1.0 and prior to version 0.3.0, the reTrimSpace regex has 2nd degree polynomial inefficiency, leading to a delayed response given a big payload. The issue has been patched in 0.3.0. As a workaround, avoid using the `replace`, `unemojify`, or `strip` functions.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-30858?

It affects 1 product.


Products: Denosaurs Emoji.

## How do I fix CVE-2023-30858?

No fix has been published for CVE-2023-30858 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-30858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-30858 and fix it if it is affected.

What it is: CVE-2023-30858 is a medium-severity denial of service vulnerability in denosaurs emoji, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-30858 exists.

Affected product: denosaurs emoji. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-30858/ (Markdown: https://insights.sbomify.com/CVE-2023-30858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-30858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-30858
- OSV: https://osv.dev/vulnerability/CVE-2023-30858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-30858/
Summaries are generated and may contain mistakes; the official description above is the record.
