CVE-2023-31007 Apache Pulsar: Broker does not always disconnect client when authentication data expires
Attackers can maintain unauthorized connections to Apache Pulsar Brokers after authentication expiry if specific non-default configurations are enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-31007?
CVE-2023-31007 is an authentication bypass vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.
This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.
2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.
Weakness: CWE-287
Which versions are affected by CVE-2023-31007?
4 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar-broker Maven | From 2.11.0 | 2.11.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.11.0 | 2.11.1 |
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.10.4 |
org.apache.pulsar:pulsar-broker Maven | From 2.9.0 | 2.10.4 |
Products include Apache Pulsar.
How do I fix CVE-2023-31007?
Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.11.1 or 2.10.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-31007 being exploited?
There is no known exploitation of CVE-2023-31007 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-47r2-phr8-m8cp.