{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-31007 in the wild and no public exploit code.","fix":"Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.11.1 or 2.10.4.","what":"CVE-2023-31007 is an authentication bypass vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-31007 and fix it if it is affected.\n\nWhat it is: CVE-2023-31007 is an authentication bypass vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-31007 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.1\n- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.1\n- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.10.4\n- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.10.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-31007/ (Markdown: https://insights.sbomify.com/CVE-2023-31007/index.md)","id":"CVE-2023-31007","markdown":"https://insights.sbomify.com/CVE-2023-31007/index.md","name":"CVE-2023-31007","record":{"aliases":["GHSA-47r2-phr8-m8cp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Pulsar Broker","requires_auth":"low_privilege","summary":"Attackers can maintain unauthorized connections to Apache Pulsar Brokers after authentication expiry if specific non-default configurations are enabled.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"pulsar","vendor":"apache"}],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.\n\nThis issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.\n\n2.9 Pulsar Broker users should upgrade to at least 2.9.5.\n2.10 Pulsar Broker users should upgrade to at least 2.10.4.\n2.11 Pulsar Broker users should upgrade to at least 2.11.1.\n3.0 Pulsar Broker users are unaffected.\nAny users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Pulsar: Broker does not always disconnect client when authentication data expires","id":"CVE-2023-31007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":4,"n_references":1,"next":{"headline":"Other in DGX H100 BMC","id":"CVE-2023-31008"},"packages":[{"ecosystem":"Maven","fixed":["2.11.1"],"introduced":["2.11.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar-broker","purl":null,"source":"GHSA-47r2-phr8-m8cp"},{"ecosystem":"Maven","fixed":["2.11.1"],"introduced":["2.11.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","source":"GHSA-47r2-phr8-m8cp"},{"ecosystem":"Maven","fixed":["2.10.4"],"introduced":["2.9.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar-broker","purl":null,"source":"GHSA-47r2-phr8-m8cp"},{"ecosystem":"Maven","fixed":["2.10.4"],"introduced":["2.9.0"],"last_affected":[],"package":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","source":"GHSA-47r2-phr8-m8cp"}],"prev":{"headline":"IBM Security Access Manager Container denial of service","id":"CVE-2023-31006"},"products":["Apache Pulsar"],"published":"2023-07-12","related":[{"cvss_score":9.8,"headline":"Authentication with JWT allows use of “none”-algorithm","id":"CVE-2021-22160","kev_date_added":null,"published":"2021-05-26"},{"cvss_score":9.6,"headline":"Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy","id":"CVE-2023-30429","kev_date_added":null,"published":"2023-07-12"},{"cvss_score":8.5,"headline":"Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution","id":"CVE-2024-27135","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.5,"headline":"Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying","id":"CVE-2024-27894","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.4,"headline":"Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification","id":"CVE-2024-27317","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.2,"headline":"Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint","id":"CVE-2022-34321","kev_date_added":null,"published":"2024-03-12"},{"cvss_score":8.2,"headline":"Apache Pulsar Broker: Incorrect Authorization Validation for Rest Producer","id":"CVE-2023-30428","kev_date_added":null,"published":"2023-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-08","vendors":["Apache Software Foundation"]},"summary":"Attackers can maintain unauthorized connections to Apache Pulsar Brokers after authentication expiry if specific non-default configurations are enabled.","url":"https://insights.sbomify.com/CVE-2023-31007/"}