# CVE-2023-31007: Apache Pulsar: Broker does not always disconnect client when authentication data expires

> Attackers can maintain unauthorized connections to Apache Pulsar Brokers after authentication expiry if specific non-default configurations are enabled.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-47r2-phr8-m8cp

## What is CVE-2023-31007?

CVE-2023-31007 is an authentication bypass vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.

This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.

2.9 Pulsar Broker users should upgrade to at least 2.9.5.
2.10 Pulsar Broker users should upgrade to at least 2.10.4.
2.11 Pulsar Broker users should upgrade to at least 2.11.1.
3.0 Pulsar Broker users are unaffected.
Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-31007?

4 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.11.0 | 2.11.1 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.11.0 | 2.11.1 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.9.0 | 2.10.4 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.9.0 | 2.10.4 |

Products: Apache Pulsar.

## How do I fix CVE-2023-31007?

Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.11.1 or 2.10.4.

## Is CVE-2023-31007 being exploited?

There is no known exploitation of CVE-2023-31007 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31007 and fix it if it is affected.

What it is: CVE-2023-31007 is an authentication bypass vulnerability in Apache Pulsar, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31007 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.1
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.1
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.10.4
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.9.0; fixed in 2.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31007/ (Markdown: https://insights.sbomify.com/CVE-2023-31007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31007
- OSV: https://osv.dev/vulnerability/CVE-2023-31007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31007/
Summaries are generated and may contain mistakes; the official description above is the record.
