# CVE-2023-31038: Apache Log4cxx: SQL injection when using ODBC appender

> Attackers can inject SQL commands via log messages in Apache Log4cxx when using the ODBC appender, potentially compromising the database.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2023
- **Updated:** 15 Oct 2024
- **Also known as:** DEBIAN-CVE-2023-31038, GHSA-76cx-3v2m-9952, UBUNTU-CVE-2023-31038, openSUSE-SU-2024:13545-1

## What is CVE-2023-31038?

CVE-2023-31038 is a high-severity SQL injection vulnerability in Apache Log4cxx, published on 8 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SQL injection in Log4cxx when using the ODBC appender to send log messages to a database.  No fields sent to the database were properly escaped for SQL injection.  This has been the case since at least version 0.9.0(released 2003-08-06)

Note that Log4cxx is a C++ framework, so only C++ applications are affected.

Before version 1.1.0, the ODBC appender was automatically part of Log4cxx if the library was found when compiling the library.  As of version 1.1.0, this must be both explicitly enabled in order to be compiled in.

Three preconditions must be met for this vulnerability to be possible:

1. Log4cxx compiled with ODBC support(before version 1.1.0, this was auto-detected at compile time)

2. ODBCAppender enabled for logging messages to, generally done via a config file

3. User input is logged at some point. If your application does not have user input, it is unlikely to be affected.

Users are recommended to upgrade to version 1.1.0 which properly binds the parameters to the SQL statement, or migrate to the new DBAppender class which supports an ODBC connection in addition to other databases. 
Note that this fix does require a configuration file update, as the old configuration files will not configure properly.  An example is shown below, and more information may be found in the Log4cxx documentation on the ODBCAppender.

Example of old configuration snippet:

<appender name="SqlODBCAppender" class="ODBCAppender">

    <param name="sql" value="INSERT INTO logs (message) VALUES ('%m')" />

    ... other params here ...

</appender>

The migrated configuration snippet with new ColumnMapping parameters:

<appender name="SqlODBCAppender" class="ODBCAppender">

    <param name="sql" value="INSERT INTO logs (message) VALUES (?)" />

    <param name="ColumnMapping" value="message"/>
    ... other params here ...

</appender>

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-31038?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `log4cxx` | openSUSE:Tumbleweed | All versions | 1.1.0-1.1 |

Products: Apache Log4cxx.

## How do I fix CVE-2023-31038?

Upgrade to a fixed version.

## Is CVE-2023-31038 being exploited?

There is no known exploitation of CVE-2023-31038 in the wild and no public exploit code.

## Other vulnerabilities in Apache Log4cxx

- [CVE-2026-40023](https://insights.sbomify.com/CVE-2026-40023/): Other in Apache Log4cxx (medium 6.3)
- [CVE-2025-54813](https://insights.sbomify.com/CVE-2025-54813/): Apache Log4cxx: Improper escaping with JSONLayout (medium 6.3)
- [CVE-2025-54812](https://insights.sbomify.com/CVE-2025-54812/): Apache Log4cxx: Improper HTML escaping in HTMLLayout (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31038 and fix it if it is affected.

What it is: CVE-2023-31038 is a high-severity SQL injection vulnerability in Apache Log4cxx, published on 8 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31038 in the wild and no public exploit code.

Affected product: Apache Log4cxx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31038/ (Markdown: https://insights.sbomify.com/CVE-2023-31038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31038
- OSV: https://osv.dev/vulnerability/CVE-2023-31038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31038/
Summaries are generated and may contain mistakes; the official description above is the record.
