# CVE-2023-31039: Apache bRPC: ServerOptions.pid_file may cause arbitrary code execution

> Attackers can execute arbitrary code by influencing the pid_file parameter in Apache bRPC server options.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8fwm-xh4w-q393

## What is CVE-2023-31039?

CVE-2023-31039 is a critical code injection vulnerability in Apache bRPC, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Security vulnerability in Apache bRPC <1.5.0 on all platforms allows attackers to execute arbitrary code via ServerOptions::pid_file.
An attacker that can influence the ServerOptions pid_file parameter with which the bRPC server is started can execute arbitrary code with the permissions of the bRPC process.

Solution:
1. upgrade to bRPC >= 1.5.0, download link:  https://dist.apache.org/repos/dist/release/brpc/1.5.0/ https://dist.apache.org/repos/dist/release/brpc/1.5.0/ 
2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch:  https://github.com/apache/brpc/pull/2218 https://github.com/apache/brpc/pull/2218

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-31039?

It affects 1 product.


Products: Apache Brpc.

## How do I fix CVE-2023-31039?

No fix has been published for CVE-2023-31039 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-31039 being exploited?

There is no known exploitation of CVE-2023-31039 in the wild and no public exploit code.

## Other vulnerabilities in Apache bRPC

- [CVE-2025-60021](https://insights.sbomify.com/CVE-2025-60021/): Apache bRPC: Remote command injection vulnerability in heap builtin service (critical 9.8)
- [CVE-2025-59789](https://insights.sbomify.com/CVE-2025-59789/): Apache bRPC: Stack Exhaustion via Unbounded Recursion in JSON Parser (high 7.5)
- [CVE-2025-54472](https://insights.sbomify.com/CVE-2025-54472/): Apache bRPC: Redis Parser Remote Denial of Service (high 7.5)
- [CVE-2024-23452](https://insights.sbomify.com/CVE-2024-23452/): Apache bRPC: HTTP request smuggling vulnerability (high 7.5)
- [CVE-2023-45757](https://insights.sbomify.com/CVE-2023-45757/): Apache bRPC: The builtin service rpcz page has an XSS attack vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31039 and fix it if it is affected.

What it is: CVE-2023-31039 is a critical code injection vulnerability in Apache bRPC, published on 8 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31039 in the wild and no public exploit code.

Affected product: Apache bRPC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31039/ (Markdown: https://insights.sbomify.com/CVE-2023-31039/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31039
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31039
- OSV: https://osv.dev/vulnerability/CVE-2023-31039

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31039/
Summaries are generated and may contain mistakes; the official description above is the record.
