# CVE-2023-31048: Exposure of Sensitive Information in OPC UA .NET Standard Reference Server

> Attackers can view sensitive information via remote error messages in the OPC UA .NET Standard Reference Server library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-4cvp-hr63-822j

## What is CVE-2023-31048?

CVE-2023-31048 is a medium-severity vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OPC UA .NET Standard Reference Server before 1.4.371.86. places sensitive information into an error message that may be seen remotely.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-31048?

4 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua.Core and OPCFoundation.NetStandard.Opc.Ua.Server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.4.371.86 |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.4.371.86 |
| `OPCFoundation.NetStandard.Opc.Ua.Server` | NuGet | All versions | 1.4.371.86 |
| `OPCFoundation.NetStandard.Opc.Ua.Server` | NuGet | All versions | 1.4.371.86 |

Products: Opcfoundation Ua-.Netstandard.

## How do I fix CVE-2023-31048?

Upgrade OPCFoundation.NetStandard.Opc.Ua.Core to 1.4.371.86 or later.

## Is CVE-2023-31048 being exploited?

There is no known exploitation of CVE-2023-31048 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-27321](https://insights.sbomify.com/CVE-2023-27321/): OPC Foundation UA .NET Standard ConditionRefresh Resource Exhaustion Denial-of-Service Vulnerability (high 7.5)
- [CVE-2020-29457](https://insights.sbomify.com/CVE-2020-29457/): Improper Certificate Validation in OPCFoundation.NetStandard.Opc.Ua.Core (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31048 and fix it if it is affected.

What it is: CVE-2023-31048 is a medium-severity vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31048 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.4.371.86
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.4.371.86
- OPCFoundation.NetStandard.Opc.Ua.Server (NuGet): affected all versions; fixed in 1.4.371.86
- OPCFoundation.NetStandard.Opc.Ua.Server (NuGet): affected all versions; fixed in 1.4.371.86

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31048/ (Markdown: https://insights.sbomify.com/CVE-2023-31048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31048
- OSV: https://osv.dev/vulnerability/CVE-2023-31048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31048/
Summaries are generated and may contain mistakes; the official description above is the record.
