CVE-2023-31065 Apache InLong: Insufficient Session Expiration in InLong

Critical 9.1 Published Updated

Attackers can reuse old sessions to access accounts even after user deletion or password changes in Apache InLong.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-31065?

CVE-2023-31065 is a critical authentication bypass vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. 

An old session can be used by an attacker even after the user has been deleted or the password has been changed.

Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.

Weakness: CWE-613

Which versions are affected by CVE-2023-31065?

8 open source packages ship an affected version, including org.apache.inlong:manager-dao, org.apache.inlong:manager-pojo and org.apache.inlong:manager-service. It affects 1 product.

PackageAffectedFixed in
org.apache.inlong:manager-dao MavenFrom 1.4.01.7.0
org.apache.inlong:manager-dao MavenFrom 1.4.01.7.0
org.apache.inlong:manager-pojo MavenFrom 1.4.01.7.0
org.apache.inlong:manager-pojo MavenFrom 1.4.01.7.0
org.apache.inlong:manager-service MavenFrom 1.4.01.7.0
org.apache.inlong:manager-service MavenFrom 1.4.01.7.0
2 more packages
org.apache.inlong:manager-web MavenFrom 1.4.01.7.0
org.apache.inlong:manager-web MavenFrom 1.4.01.7.0

Products include Apache Inlong.

How do I fix CVE-2023-31065?

Upgrade org.apache.inlong:manager-dao to 1.7.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-31065 being exploited?

There is no known exploitation of CVE-2023-31065 in the wild and no public exploit code.

Sources

Also known as GHSA-757p-7hp5-pqmr.

Is CVE-2023-31065 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free