# CVE-2023-31065: Apache InLong: Insufficient Session Expiration in InLong

> Attackers can reuse old sessions to access accounts even after user deletion or password changes in Apache InLong.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-757p-7hp5-pqmr

## What is CVE-2023-31065?

CVE-2023-31065 is a critical authentication bypass vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. 

An old session can be used by an attacker even after the user has been deleted or the password has been changed.

Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick  https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 ,  https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884  to solve it.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-31065?

8 open source packages ship an affected version, including org.apache.inlong:manager-dao, org.apache.inlong:manager-pojo and org.apache.inlong:manager-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.inlong:manager-dao` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-dao` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-pojo` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-pojo` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-service` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-service` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-web` | Maven | From 1.4.0 | 1.7.0 |
| `org.apache.inlong:manager-web` | Maven | From 1.4.0 | 1.7.0 |

Products: Apache Inlong.

## How do I fix CVE-2023-31065?

Upgrade org.apache.inlong:manager-dao to 1.7.0 or later.

## Is CVE-2023-31065 being exploited?

There is no known exploitation of CVE-2023-31065 in the wild and no public exploit code.

## Other vulnerabilities in Apache InLong

- [CVE-2026-63037](https://insights.sbomify.com/CVE-2026-63037/): Apache InLong: Unauthenticated SQL injection in Manager OpenAPI audit alert rule list endpoint (critical 9.8)
- [CVE-2026-63038](https://insights.sbomify.com/CVE-2026-63038/): Apache InLong: SQL Injection via String Concatenation Vulnerability Report (critical 9.8)
- [CVE-2026-63039](https://insights.sbomify.com/CVE-2026-63039/): Apache InLong: SQL Injection via Unvalidated MyBatis Dollar-Sign Interpolation in AuditAlertRuleService (critical 9.8)
- [CVE-2025-27531](https://insights.sbomify.com/CVE-2025-27531/): Apache InLong: An arbitrary file read vulnerability for JDBC (critical 9.8)
- [CVE-2024-26579](https://insights.sbomify.com/CVE-2024-26579/): Apache Inlong JDBC Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31065 and fix it if it is affected.

What it is: CVE-2023-31065 is a critical authentication bypass vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31065 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.inlong:manager-dao (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-dao (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-pojo (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-pojo (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-service (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-service (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-web (Maven): affected from 1.4.0; fixed in 1.7.0
- org.apache.inlong:manager-web (Maven): affected from 1.4.0; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31065/ (Markdown: https://insights.sbomify.com/CVE-2023-31065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31065
- OSV: https://osv.dev/vulnerability/CVE-2023-31065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31065/
Summaries are generated and may contain mistakes; the official description above is the record.
