CVE-2023-31098 Apache InLong: Weak Password Implementation in InLong

Critical 9.8 Published Updated

Weak password requirements in Apache InLong allow attackers to easily guess user passwords and take over accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-31098?

CVE-2023-31098 is a critical vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0. 

When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account.

Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.

Weakness: CWE-521

Which versions are affected by CVE-2023-31098?

2 open source packages ship an affected version, including org.apache.inlong:manager-pojo. It affects 1 product.

PackageAffectedFixed in
org.apache.inlong:manager-pojo MavenFrom 1.1.01.47.0
org.apache.inlong:manager-pojo MavenFrom 1.1.01.47.0

Products include Apache Inlong.

How do I fix CVE-2023-31098?

Upgrade org.apache.inlong:manager-pojo to 1.47.0 or later.

Is CVE-2023-31098 being exploited?

There is no known exploitation of CVE-2023-31098 in the wild and no public exploit code.

Sources

Also known as GHSA-w3wr-gmwf-r333.

Is CVE-2023-31098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free