{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.inlong:manager-pojo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-31098 in the wild and no public exploit code.","fix":"Upgrade org.apache.inlong:manager-pojo to 1.47.0 or later.","what":"CVE-2023-31098 is a critical vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-31098 and fix it if it is affected.\n\nWhat it is: CVE-2023-31098 is a critical vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-31098 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.inlong:manager-pojo (Maven): affected from 1.1.0; fixed in 1.47.0\n- org.apache.inlong:manager-pojo (Maven): affected from 1.1.0; fixed in 1.47.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-31098/ (Markdown: https://insights.sbomify.com/CVE-2023-31098/index.md)","id":"CVE-2023-31098","markdown":"https://insights.sbomify.com/CVE-2023-31098/index.md","name":"CVE-2023-31098","record":{"aliases":["GHSA-w3wr-gmwf-r333"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache InLong","requires_auth":"none","summary":"Weak password requirements in Apache InLong allow attackers to easily guess user passwords and take over accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"inlong","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0. \n\nWhen users change their password to a simple password (with any character or\nsymbol), attackers can easily guess the user's password and access the account.\n\nUsers are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick  https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805  to solve it.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache InLong: Weak Password Implementation in InLong","id":"CVE-2023-31098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Code injection in n/a","id":"CVE-2023-31099"},"packages":[{"ecosystem":"Maven","fixed":["1.47.0"],"introduced":["1.1.0"],"last_affected":[],"package":"org.apache.inlong:manager-pojo","purl":null,"source":"GHSA-w3wr-gmwf-r333"},{"ecosystem":"Maven","fixed":["1.47.0"],"introduced":["1.1.0"],"last_affected":[],"package":"org.apache.inlong:manager-pojo","purl":"pkg:maven/org.apache.inlong/manager-pojo","source":"GHSA-w3wr-gmwf-r333"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2023-31096"},"products":["Apache InLong"],"published":"2023-05-22","related":[{"cvss_score":9.8,"headline":"Apache InLong: Unauthenticated SQL injection in Manager OpenAPI audit alert rule list endpoint","id":"CVE-2026-63037","kev_date_added":null,"published":"2026-08-20"},{"cvss_score":9.8,"headline":"Apache InLong: SQL Injection via String Concatenation Vulnerability Report","id":"CVE-2026-63038","kev_date_added":null,"published":"2026-08-20"},{"cvss_score":9.8,"headline":"Apache InLong: SQL Injection via Unvalidated MyBatis Dollar-Sign Interpolation in AuditAlertRuleService","id":"CVE-2026-63039","kev_date_added":null,"published":"2026-08-20"},{"cvss_score":9.8,"headline":"Apache InLong: An arbitrary file read vulnerability for JDBC","id":"CVE-2025-27531","kev_date_added":null,"published":"2025-06-06"},{"cvss_score":9.8,"headline":"Apache Inlong JDBC Vulnerability","id":"CVE-2024-26579","kev_date_added":null,"published":"2024-05-08"},{"cvss_score":9.8,"headline":"Apache InLong: Remote Code Execution vulnerability in Apache InLong Manager","id":"CVE-2023-51784","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.8,"headline":"Apache InLong: Jdbc Connection Security Bypass in InLong","id":"CVE-2023-43668","kev_date_added":null,"published":"2023-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-11","vendors":["Apache Software Foundation"]},"summary":"Weak password requirements in Apache InLong allow attackers to easily guess user passwords and take over accounts.","url":"https://insights.sbomify.com/CVE-2023-31098/"}