# CVE-2023-31098: Apache InLong: Weak Password Implementation in InLong

> Weak password requirements in Apache InLong allow attackers to easily guess user passwords and take over accounts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2023
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-w3wr-gmwf-r333

## What is CVE-2023-31098?

CVE-2023-31098 is a critical vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0. 

When users change their password to a simple password (with any character or
symbol), attackers can easily guess the user's password and access the account.

Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick  https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805  to solve it.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2023-31098?

2 open source packages ship an affected version, including org.apache.inlong:manager-pojo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.inlong:manager-pojo` | Maven | From 1.1.0 | 1.47.0 |
| `org.apache.inlong:manager-pojo` | Maven | From 1.1.0 | 1.47.0 |

Products: Apache Inlong.

## How do I fix CVE-2023-31098?

Upgrade org.apache.inlong:manager-pojo to 1.47.0 or later.

## Is CVE-2023-31098 being exploited?

There is no known exploitation of CVE-2023-31098 in the wild and no public exploit code.

## Other vulnerabilities in Apache InLong

- [CVE-2026-63037](https://insights.sbomify.com/CVE-2026-63037/): Apache InLong: Unauthenticated SQL injection in Manager OpenAPI audit alert rule list endpoint (critical 9.8)
- [CVE-2026-63038](https://insights.sbomify.com/CVE-2026-63038/): Apache InLong: SQL Injection via String Concatenation Vulnerability Report (critical 9.8)
- [CVE-2026-63039](https://insights.sbomify.com/CVE-2026-63039/): Apache InLong: SQL Injection via Unvalidated MyBatis Dollar-Sign Interpolation in AuditAlertRuleService (critical 9.8)
- [CVE-2025-27531](https://insights.sbomify.com/CVE-2025-27531/): Apache InLong: An arbitrary file read vulnerability for JDBC (critical 9.8)
- [CVE-2024-26579](https://insights.sbomify.com/CVE-2024-26579/): Apache Inlong JDBC Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31098 and fix it if it is affected.

What it is: CVE-2023-31098 is a critical vulnerability in Apache InLong, published on 22 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31098 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.inlong:manager-pojo (Maven): affected from 1.1.0; fixed in 1.47.0
- org.apache.inlong:manager-pojo (Maven): affected from 1.1.0; fixed in 1.47.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31098/ (Markdown: https://insights.sbomify.com/CVE-2023-31098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31098
- OSV: https://osv.dev/vulnerability/CVE-2023-31098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31098/
Summaries are generated and may contain mistakes; the official description above is the record.
