CVE-2023-31125 Uncaught exception in engine.io
A specially crafted HTTP request triggers an uncaught exception in Engine.IO, crashing the Node.js process and causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-31125?
CVE-2023-31125 is a medium-severity denial of service vulnerability in socketio engine.io, published on 8 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Engine.IO is the implementation of transport-based cross-browser/cross-device bi-directional communication layer for Socket.IO. An uncaught exception vulnerability was introduced in version 5.1.0 and included in version 4.1.0 of the `socket.io` parent package. Older versions are not impacted. A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process. This impacts all the users of the `engine.io` package, including those who use depending packages like `socket.io`. This issue was fixed in version 6.4.2 of Engine.IO. There is no known workaround except upgrading to a safe version.
Weakness: CWE-248
Which versions are affected by CVE-2023-31125?
2 open source packages ship an affected version, including engine.io. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
engine.io npm | From 5.1.0 | 6.4.2 |
engine.io npm | From 5.1.0 | 6.4.2 |
Products include Socket Engine.io.
How do I fix CVE-2023-31125?
Upgrade engine.io to 6.4.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-31125 being exploited?
There is no known exploitation of CVE-2023-31125 in the wild and no public exploit code.
Other vulnerabilities in socketio engine.io
Sources
Also known as GHSA-q9mw-68c2-j6m5.