# CVE-2023-31126: Improper Neutralization of Invalid Characters in Data Attribute Names in org.xwiki.commons:xwiki-commons-xml

> Attackers can inject arbitrary HTML and execute scripts via invalid data attributes in the XWiki XML library, requiring an upgrade to patched versions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2023
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-pv7v-ph6g-3gxv

## What is CVE-2023-31126?

CVE-2023-31126 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 9 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

`org.xwiki.commons:xwiki-commons-xml` is an XML library used by the open-source wiki platform XWiki. The HTML sanitizer, introduced in version 14.6-rc-1, allows the injection of arbitrary HTML code and thus cross-site scripting via invalid data attributes. This vulnerability does not affect restricted cleaning in HTMLCleaner as there attributes are cleaned and thus characters like `/` and `>` are removed in all attribute names. This problem has been patched in XWiki 14.10.4 and 15.0 RC1 by making sure that data attributes only contain allowed characters. There are no known workarounds apart from upgrading to a version including the fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-86 (Improper Neutralization of Invalid Characters in Identifiers in Web Pages)

## Which versions are affected by CVE-2023-31126?

2 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-xml` | Maven | From 14.6-rc-1 | 14.10.4 |
| `org.xwiki.commons:xwiki-commons-xml` | Maven | From 14.6-rc-1 | 14.10.4 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-31126?

Upgrade org.xwiki.commons:xwiki-commons-xml to 14.10.4 or later.

## Is CVE-2023-31126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31126 exists.

Public exploit code:

- https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2023-31126_14-10-3 (github_poc): https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2023-31126_14-10-3
- XWiki Commons CVE-2023-31126 v14.10.3 for Coverity analysis (github_poc): https://github.com/shoucheng3/cov-int

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31126 and fix it if it is affected.

What it is: CVE-2023-31126 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 9 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31126 exists.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-xml (Maven): affected from 14.6-rc-1; fixed in 14.10.4
- org.xwiki.commons:xwiki-commons-xml (Maven): affected from 14.6-rc-1; fixed in 14.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31126/ (Markdown: https://insights.sbomify.com/CVE-2023-31126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31126
- OSV: https://osv.dev/vulnerability/CVE-2023-31126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31126/
Summaries are generated and may contain mistakes; the official description above is the record.
