CVE-2023-31131 Arbitrary File Write when Extracting Tarballs in greenplum-db

High 7.4 Published Updated

Attackers can overwrite system files via path traversal in tarball extraction, potentially causing system crashes or data loss.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-31131?

CVE-2023-31131 is a high-severity path traversal vulnerability in greenplum-db gpdb, published on 15 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Greenplum Database (GPDB) is an open source data warehouse based on PostgreSQL. In versions prior to 6.22.3 Greenplum Database used an unsafe methods to extract tar files within GPPKGs. greenplum-db is vulnerable to path traversal leading to arbitrary file writes. An attacker can use this vulnerability to overwrite data or system files potentially leading to crash or malfunction of the system. Any files which are accessible to the running process are at risk. All users are requested to upgrade to Greenplum Database version 6.23.2 or higher. There are no known workarounds for this vulnerability.

Weakness: CWE-22

Which versions are affected by CVE-2023-31131?

It affects 1 product.

Products include Vmware Greenplum Database.

How do I fix CVE-2023-31131?

No fix has been published for CVE-2023-31131 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-31131 being exploited?

There is no known exploitation of CVE-2023-31131 in the wild and no public exploit code.

Sources

Is CVE-2023-31131 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free