# CVE-2023-31131: Arbitrary File Write when Extracting Tarballs in greenplum-db

> Attackers can overwrite system files via path traversal in tarball extraction, potentially causing system crashes or data loss.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2023
- **Updated:** 22 Jan 2025

## What is CVE-2023-31131?

CVE-2023-31131 is a high-severity path traversal vulnerability in greenplum-db gpdb, published on 15 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Greenplum Database (GPDB) is an open source data warehouse based on PostgreSQL. In versions prior to 6.22.3 Greenplum Database used an unsafe methods to extract tar files within GPPKGs. greenplum-db is vulnerable to path traversal leading to arbitrary file writes. An attacker can use this vulnerability to overwrite data or system files potentially leading to crash or malfunction of the system. Any files which are accessible to the running process are at risk. All users are requested to upgrade to Greenplum Database version 6.23.2 or higher. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-31131?

It affects 1 product.


Products: Vmware Greenplum Database.

## How do I fix CVE-2023-31131?

No fix has been published for CVE-2023-31131 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-31131 being exploited?

There is no known exploitation of CVE-2023-31131 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31131 and fix it if it is affected.

What it is: CVE-2023-31131 is a high-severity path traversal vulnerability in greenplum-db gpdb, published on 15 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31131 in the wild and no public exploit code.

Affected product: greenplum-db gpdb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31131/ (Markdown: https://insights.sbomify.com/CVE-2023-31131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31131
- OSV: https://osv.dev/vulnerability/CVE-2023-31131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31131/
Summaries are generated and may contain mistakes; the official description above is the record.
