# CVE-2023-31136: PostgresNIO processes unencrypted bytes from man-in-the-middle

> A man-in-the-middle attacker can inject false responses to initial queries in PostgresNIO despite TLS encryption, compromising data integrity.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2023
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-9cfh-vx93-84vv

## What is CVE-2023-31136?

CVE-2023-31136 is a low-severity vulnerability in vapor postgres-nio, published on 9 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PostgresNIO is a Swift client for PostgreSQL. Any user of PostgresNIO prior to version 1.14.2 connecting to servers with TLS enabled is vulnerable to a man-in-the-middle attacker injecting false responses to the client's first few queries, despite the use of TLS certificate verification and encryption. The vulnerability is addressed in PostgresNIO versions starting from 1.14.2. There are no known workarounds for unpatched users.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-31136?

2 open source packages ship an affected version, including github.com/vapor/postgres-nio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vapor/postgres-nio` | SwiftURL | All versions | 1.14.2 |
| `github.com/vapor/postgres-nio` | SwiftURL | All versions | 1.14.2 |

Products: Vapor Postgresnio.

## How do I fix CVE-2023-31136?

Upgrade github.com/vapor/postgres-nio to 1.14.2 or later.

## Is CVE-2023-31136 being exploited?

There is no known exploitation of CVE-2023-31136 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31136 and fix it if it is affected.

What it is: CVE-2023-31136 is a low-severity vulnerability in vapor postgres-nio, published on 9 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31136 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/vapor/postgres-nio (SwiftURL): affected all versions; fixed in 1.14.2
- github.com/vapor/postgres-nio (SwiftURL): affected all versions; fixed in 1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31136/ (Markdown: https://insights.sbomify.com/CVE-2023-31136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31136
- OSV: https://osv.dev/vulnerability/CVE-2023-31136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31136/
Summaries are generated and may contain mistakes; the official description above is the record.
