# CVE-2023-31140: OpenProject user sessions not terminated after activation of 2FA

> Attackers can maintain access via existing sessions after a user enables two-factor authentication, bypassing the intended security control.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2023
- **Updated:** 29 Jan 2025
- **Also known as:** BIT-openproject-2023-31140, GHSA-xfp9-qqfj-x28q

## What is CVE-2023-31140?

CVE-2023-31140 is a medium-severity vulnerability in opf openproject, published on 8 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenProject is open source project management software. Starting with version 7.4.0 and prior to version 12.5.4, when a user registers and confirms their first two-factor authentication (2FA) device for an account, existing logged in sessions for that user account are not terminated. Likewise, if an administrators creates a mobile phone 2FA device on behalf of a user, their existing sessions are not terminated. The issue has been resolved in OpenProject version 12.5.4 by actively terminating sessions of user accounts having registered and confirmed a 2FA device. As a workaround, users who register the first 2FA device on their account can manually log out to terminate all other active sessions. This is the default behavior of OpenProject but might be disabled through a configuration option. Double check that this option is not overridden if one plans to employ the workaround.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-31140?

1 open source package ship an affected version, including openproject. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openproject` | Bitnami | From 7.4.0 | 12.5.4 |

Products: Openproject Openproject.

## How do I fix CVE-2023-31140?

Upgrade openproject to 12.5.4 or later.

## Is CVE-2023-31140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31140 exists.

## Other vulnerabilities in opf openproject

- [CVE-2026-34717](https://insights.sbomify.com/CVE-2026-34717/): OpenProject: SQL Injection in Cost Reporting =n Operator via parse_number_string (critical 9.9)
- [CVE-2026-25763](https://insights.sbomify.com/CVE-2026-25763/): Command Injection on OpenProject repositories leads to Remote Code Execution (critical 9.4)
- [CVE-2026-24685](https://insights.sbomify.com/CVE-2026-24685/): OpenProject has Argument Injection on Repository module that allows Arbitrary File Write (critical 9.4)
- [CVE-2026-32698](https://insights.sbomify.com/CVE-2026-32698/): OpenProject has a SQL Injection via Custom Field Name that can be chained to Remote Code Execution (critical 9.1)
- [CVE-2026-32703](https://insights.sbomify.com/CVE-2026-32703/): OpenProject's repository files are served with the MIME type allowing them to be used to bypass Content Security Policy (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31140 and fix it if it is affected.

What it is: CVE-2023-31140 is a medium-severity vulnerability in opf openproject, published on 8 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31140 exists.

Affected packages and fixed versions:
- openproject (Bitnami): affected from 7.4.0; fixed in 12.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31140/ (Markdown: https://insights.sbomify.com/CVE-2023-31140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31140
- OSV: https://osv.dev/vulnerability/CVE-2023-31140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31140/
Summaries are generated and may contain mistakes; the official description above is the record.
