CVE-2023-31141 OpenSearch issue with fine-grained access control during extremely rare race conditions
A race condition in OpenSearch's fine-grained access control can bypass document and field-level security restrictions during rare cache evictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-31141?
CVE-2023-31141 is a medium-severity vulnerability in opensearch-project security, published on 8 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OpenSearch is open-source software suite for search, analytics, and observability applications. Prior to versions 1.3.10 and 2.7.0, there is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the queries during extremely rare race conditions potentially leading to incorrect access authorization. For this issue to be triggered, two concurrent requests need to land on the same instance exactly when query cache eviction happens, once every four hours. OpenSearch 1.3.10 and 2.7.0 contain a fix for this issue.
Weakness: CWE-863
Which versions are affected by CVE-2023-31141?
4 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.opensearch.plugin:opensearch-security Maven | From 1.0.0 | 1.3.10.0 |
org.opensearch.plugin:opensearch-security Maven | From 1.0.0 | 1.3.10.0 |
org.opensearch.plugin:opensearch-security Maven | From 2.0.0 | 2.7.0.0 |
org.opensearch.plugin:opensearch-security Maven | From 2.0.0 | 2.7.0.0 |
Products include Amazon Opensearch, Amazon Opensearch Security.
How do I fix CVE-2023-31141?
Upgrade org.opensearch.plugin:opensearch-security to a fixed version for your release line: 1.3.10.0 or 2.7.0.0.
Is CVE-2023-31141 being exploited?
There is no known exploitation of CVE-2023-31141 in the wild and no public exploit code.
Other vulnerabilities in opensearch-project security
- CVE-2022-31115 Unsafe YAML deserialization in opensearch-ruby
- CVE-2025-9624 OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS
- CVE-2022-35980 OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information
- CVE-2022-41918 Issue with fine-grained access control of indices backing data streams
- CVE-2023-23933 Issue in Anomaly Detection with document and field level rules in numerical feature aggregations
Sources
Also known as GHSA-g8xc-6mf7-h28h, UBUNTU-CVE-2023-31141.