# CVE-2023-31141: OpenSearch issue with fine-grained access control during extremely rare race conditions

> A race condition in OpenSearch's fine-grained access control can bypass document and field-level security restrictions during rare cache evictions.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2023
- **Updated:** 29 Jan 2025
- **Also known as:** GHSA-g8xc-6mf7-h28h, UBUNTU-CVE-2023-31141

## What is CVE-2023-31141?

CVE-2023-31141 is a medium-severity vulnerability in opensearch-project security, published on 8 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenSearch is open-source software suite for search, analytics, and observability applications. Prior to versions 1.3.10 and 2.7.0, there is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the queries during extremely rare race conditions potentially leading to incorrect access authorization. For this issue to be triggered, two concurrent requests need to land on the same instance exactly when query cache eviction happens, once every four hours. OpenSearch 1.3.10 and 2.7.0 contain a fix for this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-31141?

4 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch.plugin:opensearch-security` | Maven | From 1.0.0 | 1.3.10.0 |
| `org.opensearch.plugin:opensearch-security` | Maven | From 1.0.0 | 1.3.10.0 |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.0.0 | 2.7.0.0 |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.0.0 | 2.7.0.0 |

Products: Amazon Opensearch, Amazon Opensearch Security.

## How do I fix CVE-2023-31141?

Upgrade org.opensearch.plugin:opensearch-security to a fixed version for your release line: 1.3.10.0 or 2.7.0.0.

## Is CVE-2023-31141 being exploited?

There is no known exploitation of CVE-2023-31141 in the wild and no public exploit code.

## Other vulnerabilities in opensearch-project security

- [CVE-2022-31115](https://insights.sbomify.com/CVE-2022-31115/): Unsafe YAML deserialization in opensearch-ruby (high 8.8)
- [CVE-2025-9624](https://insights.sbomify.com/CVE-2025-9624/): OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS (high 8.3)
- [CVE-2022-35980](https://insights.sbomify.com/CVE-2022-35980/): OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information (high 7.5)
- [CVE-2022-41918](https://insights.sbomify.com/CVE-2022-41918/): Issue with fine-grained access control of indices backing data streams (medium 6.3)
- [CVE-2023-23933](https://insights.sbomify.com/CVE-2023-23933/): Issue in Anomaly Detection with document and field level rules in numerical feature aggregations (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31141 and fix it if it is affected.

What it is: CVE-2023-31141 is a medium-severity vulnerability in opensearch-project security, published on 8 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-31141 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensearch.plugin:opensearch-security (Maven): affected from 1.0.0; fixed in 1.3.10.0
- org.opensearch.plugin:opensearch-security (Maven): affected from 1.0.0; fixed in 1.3.10.0
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0; fixed in 2.7.0.0
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0; fixed in 2.7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31141/ (Markdown: https://insights.sbomify.com/CVE-2023-31141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31141
- OSV: https://osv.dev/vulnerability/CVE-2023-31141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31141/
Summaries are generated and may contain mistakes; the official description above is the record.
