CVE-2023-31142 Discourse's general category permissions could be set back to default

Low 2.0 Published Updated

Discourse may reset custom category permissions to defaults, potentially exposing restricted content to unauthorized users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-31142?

CVE-2023-31142 is a low-severity vulnerability in Discourse Discourse, published on 13 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, if a site has modified their general category permissions, they could be set back to the default. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. A workaround, only if you are modifying the general category permissions, is to use a new category for the same purpose.

Weakness: CWE-732

Which versions are affected by CVE-2023-31142?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.4

Products include Discourse Discourse.

How do I fix CVE-2023-31142?

Upgrade discourse to 3.0.4 or later.

Is CVE-2023-31142 being exploited?

There is no known exploitation of CVE-2023-31142 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-31142, GHSA-286w-97m2-78x2.

Is CVE-2023-31142 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free