# CVE-2023-31142: Discourse's general category permissions could be set back to default

> Discourse may reset custom category permissions to defaults, potentially exposing restricted content to unauthorized users.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2023
- **Updated:** 2 Jan 2025
- **Also known as:** BIT-discourse-2023-31142, GHSA-286w-97m2-78x2

## What is CVE-2023-31142?

CVE-2023-31142 is a low-severity vulnerability in Discourse Discourse, published on 13 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, if a site has modified their general category permissions, they could be set back to the default. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. A workaround, only if you are modifying the general category permissions, is to use a new category for the same purpose.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-31142?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.0.4 |

Products: Discourse Discourse.

## How do I fix CVE-2023-31142?

Upgrade discourse to 3.0.4 or later.

## Is CVE-2023-31142 being exploited?

There is no known exploitation of CVE-2023-31142 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31142 and fix it if it is affected.

What it is: CVE-2023-31142 is a low-severity vulnerability in Discourse Discourse, published on 13 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-31142 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31142/ (Markdown: https://insights.sbomify.com/CVE-2023-31142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31142
- OSV: https://osv.dev/vulnerability/CVE-2023-31142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31142/
Summaries are generated and may contain mistakes; the official description above is the record.
