{"answers":{"affected":"3 open source packages ship an affected version, including mage-ai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-31143 in the wild and no public exploit code.","fix":"Upgrade mage-ai to 0.8.72 or later.","what":"CVE-2023-31143 is a medium-severity missing authorization vulnerability in mage-ai, published on 9 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-31143 and fix it if it is affected.\n\nWhat it is: CVE-2023-31143 is a medium-severity missing authorization vulnerability in mage-ai, published on 9 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-31143 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mage-ai (PyPI): affected from 0.8.34; fixed in 0.8.72\n- mage-ai (PyPI): affected from 0.8.34; fixed in 0.8.72\n- mage-ai (PyPI): affected from 0.8.34; fixed in 0.8.72\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-31143/ (Markdown: https://insights.sbomify.com/CVE-2023-31143/index.md)","id":"CVE-2023-31143","markdown":"https://insights.sbomify.com/CVE-2023-31143/index.md","name":"CVE-2023-31143","record":{"aliases":["GHSA-c6mm-2g84-v4m7","PYSEC-2023-64"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Mage data pipeline tool","requires_auth":"none","summary":"Unauthenticated users can access the terminal in Mage data pipeline tool when authentication is enabled, allowing unauthorized code execution.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mage-ai","vendor":"mage"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"mage-ai is an open-source data pipeline tool for transforming and integrating data. Those who use Mage starting in version 0.8.34 and prior to 0.8.72 with user authentication enabled may be affected by a vulnerability. The terminal could be accessed by users who are not signed in or do not have editor permissions. Version 0.8.72 contains a fix for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mage terminal user authentication not working properly","id":"CVE-2023-31143","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Craft CMS vulnerable to cross site scripting in RSS feed widget","id":"CVE-2023-31144"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.72"],"introduced":["0.8.34"],"last_affected":[],"package":"mage-ai","purl":null,"source":"GHSA-c6mm-2g84-v4m7"},{"ecosystem":"PyPI","fixed":["0.8.72"],"introduced":["0.8.34"],"last_affected":[],"package":"mage-ai","purl":"pkg:pypi/mage-ai","source":"GHSA-c6mm-2g84-v4m7"},{"ecosystem":"PyPI","fixed":["0.8.72"],"introduced":["0.8.34"],"last_affected":[],"package":"mage-ai","purl":"pkg:pypi/mage-ai","source":"PYSEC-2023-64"}],"prev":{"headline":"Discourse's general category permissions could be set back to default","id":"CVE-2023-31142"},"products":["mage-ai"],"published":"2023-05-09","related":[{"cvss_score":7.1,"headline":"Mage AI allows deleted users to use the terminal server with admin access, leading to remote code execution","id":"CVE-2024-45187","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":6.5,"headline":"Mage AI file content request remote arbitrary file leak","id":"CVE-2024-45188","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":6.5,"headline":"Mage AI git content request remote arbitrary file leak","id":"CVE-2024-45189","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":6.5,"headline":"Mage AI pipeline interaction request remote arbitrary file leak","id":"CVE-2024-45190","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":5.3,"headline":"Mage AI allows remote unauthenticated attackers to leak the terminal server command history of arbitrary users","id":"CVE-2024-8072","kev_date_added":null,"published":"2024-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-28","vendors":["mage-ai"]},"summary":"Unauthenticated users can access the terminal in Mage data pipeline tool when authentication is enabled, allowing unauthorized code execution.","url":"https://insights.sbomify.com/CVE-2023-31143/"}