CVE-2023-31144 Craft CMS vulnerable to cross site scripting in RSS feed widget
Attackers can inject malicious scripts via malformed RSS feed titles in Craft CMS, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-31144?
CVE-2023-31144 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 9 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.
Weakness: CWE-79
Which versions are affected by CVE-2023-31144?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 3.0.0 | 3.8.4 |
craftcms/cms Packagist | From 3.0.0 | 3.8.4 |
craftcms/cms Packagist | From 4.0.0 | 4.4.4 |
craftcms/cms Packagist | From 4.0.0 | 4.4.4 |
Products include Craftcms Craft Cms.
How do I fix CVE-2023-31144?
Upgrade craftcms/cms to a fixed version for your release line: 3.8.4 or 4.4.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-31144 being exploited?
There is no known exploitation of CVE-2023-31144 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-j4mx-98hw-6rv6.