# CVE-2023-31144: Craft CMS vulnerable to cross site scripting in RSS feed widget

> Attackers can inject malicious scripts via malformed RSS feed titles in Craft CMS, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2023
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-j4mx-98hw-6rv6

## What is CVE-2023-31144?

CVE-2023-31144 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 9 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-31144?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 3.0.0 | 3.8.4 |
| `craftcms/cms` | Packagist | From 3.0.0 | 3.8.4 |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.4.4 |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.4.4 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2023-31144?

Upgrade craftcms/cms to a fixed version for your release line: 3.8.4 or 4.4.4.

## Is CVE-2023-31144 being exploited?

There is no known exploitation of CVE-2023-31144 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31144 and fix it if it is affected.

What it is: CVE-2023-31144 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 9 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-31144 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.8.4
- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.8.4
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.4.4
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31144/ (Markdown: https://insights.sbomify.com/CVE-2023-31144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31144
- OSV: https://osv.dev/vulnerability/CVE-2023-31144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31144/
Summaries are generated and may contain mistakes; the official description above is the record.
