# CVE-2023-31146: Vyper vulnerable to OOB DynArray access when array is on both LHS and RHS of an assignment

> Out-of-bounds array access in Vyper compiler can cause data corruption across call frames, potentially leading to code execution in smart contracts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2023
- **Updated:** 24 Jan 2025
- **Also known as:** GHSA-3p37-3636-q8wv, PYSEC-2023-77

## What is CVE-2023-31146?

CVE-2023-31146 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 11 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, during codegen, the length word of a dynarray is written before the data, which can result in out-of-bounds array access in the case where the dynarray is on both the lhs and rhs of an assignment. The issue can cause data corruption across call frames. The expected behavior is to revert due to out-of-bounds array access. Version 0.3.8 contains a patch for this issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-31146?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-31146?

Upgrade vyper to 0.3.8 or later.

## Is CVE-2023-31146 being exploited?

There is no known exploitation of CVE-2023-31146 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31146 and fix it if it is affected.

What it is: CVE-2023-31146 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 11 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31146 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31146/ (Markdown: https://insights.sbomify.com/CVE-2023-31146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31146
- OSV: https://osv.dev/vulnerability/CVE-2023-31146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31146/
Summaries are generated and may contain mistakes; the official description above is the record.
