CVE-2023-3115 Incorrect User Management in GitLab

Medium 5.4 Published Updated

Attackers can bypass Single Sign On restrictions to access public members-only project repositories as indirect members in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3115?

CVE-2023-3115 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions affecting all versions from 11.11 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. Single Sign On restrictions were not correctly enforced for indirect project members accessing public members-only project repositories.

Weakness: CWE-286

Which versions are affected by CVE-2023-3115?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.11.016.2.8, 16.3.5, 16.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3115?

Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-3115 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3115 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3115, GHSA-5x88-x3vg-442p.

Is CVE-2023-3115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free