# CVE-2023-31285: Cross Site Scripting (XSS) in Serenity

> Attackers can upload HTML files with XSS payloads to trick administrators into executing malicious scripts, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-93h6-wx7r-mgfp

## What is CVE-2023-31285?

CVE-2023-31285 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS issue was discovered in Serenity Serene (and StartSharp) before 6.7.0. When users upload temporary files, some specific file endings are not allowed, but it is possible to upload .html or .htm files containing an XSS payload. The resulting link can be sent to an administrator user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-31285?

4 open source packages ship an affected version, including Serenity.Net.Core and Serenity.Net.Services. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Serenity.Net.Core` | NuGet | All versions | 6.7.0 |
| `Serenity.Net.Core` | NuGet | All versions | 6.7.0 |
| `Serenity.Net.Services` | NuGet | All versions | 6.7.0 |
| `Serenity.Net.Services` | NuGet | All versions | 6.7.0 |

Products: Serenity Serene, Serenity Startsharp.

## How do I fix CVE-2023-31285?

Upgrade Serenity.Net.Core to 6.7.0 or later.

## Is CVE-2023-31285 being exploited?

There is no known exploitation of CVE-2023-31285 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-31287](https://insights.sbomify.com/CVE-2023-31287/): Insufficient token expiration in Serenity (high 7.8)
- [CVE-2023-31286](https://insights.sbomify.com/CVE-2023-31286/): User account enumeration in Serenity (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31285 and fix it if it is affected.

What it is: CVE-2023-31285 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-31285 in the wild and no public exploit code.

Affected packages and fixed versions:
- Serenity.Net.Core (NuGet): affected all versions; fixed in 6.7.0
- Serenity.Net.Core (NuGet): affected all versions; fixed in 6.7.0
- Serenity.Net.Services (NuGet): affected all versions; fixed in 6.7.0
- Serenity.Net.Services (NuGet): affected all versions; fixed in 6.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31285/ (Markdown: https://insights.sbomify.com/CVE-2023-31285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31285
- OSV: https://osv.dev/vulnerability/CVE-2023-31285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31285/
Summaries are generated and may contain mistakes; the official description above is the record.
