# CVE-2023-31543: pipreqs vulnerable to Dependency Confusion

> Attackers can execute arbitrary code by exploiting dependency confusion in pipreqs via malicious PyPI packages.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 26 Nov 2024
- **Also known as:** GHSA-v4f4-23wc-99mh, PYSEC-2023-99, openSUSE-SU-2024:13041-1, openSUSE-SU-2026:12026-1

## What is CVE-2023-31543?

CVE-2023-31543 is a critical vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2023-31543?

3 open source packages ship an affected version, including pipreqs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pipreqs` | PyPI | From 0.3.0 | 0.4.12 |
| `pipreqs` | PyPI | From 0.3.0 | 0.4.12 |
| `pipreqs` | PyPI | From 0.3.0 | 0.4.12 |
| `python-pipreqs` | openSUSE:Tumbleweed | All versions | 0.5.0-2.2 |

Products: Pipreqs Project Pipreqs.

## How do I fix CVE-2023-31543?

Upgrade pipreqs to 0.4.12 or later.

## Is CVE-2023-31543 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31543 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31543 and fix it if it is affected.

What it is: CVE-2023-31543 is a critical vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31543 exists.

Affected packages and fixed versions:
- pipreqs (PyPI): affected from 0.3.0; fixed in 0.4.12
- pipreqs (PyPI): affected from 0.3.0; fixed in 0.4.12
- pipreqs (PyPI): affected from 0.3.0; fixed in 0.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31543/ (Markdown: https://insights.sbomify.com/CVE-2023-31543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31543
- OSV: https://osv.dev/vulnerability/CVE-2023-31543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31543/
Summaries are generated and may contain mistakes; the official description above is the record.
